Gen
15

Problema di funzionamento dell’editor WYSIWYG di WordPress 2.7 con il plugin WPG2

Dopo avere aggiornato questo blog alla nuova versione di WordPress, ho notato l’impossibilità di utilizzare l’editor WYSIWYG incluso; ho indagato a fondo disabilitando, uno per uno, i plugin fino a quando il problema non si è risolto e ho capito che la limitazione era causata dal plugin WPG2.

Cercando su Google, ho capito che il baco è causato da una vecchia funzione “chiamata” nel file di lingua di WPG2. Comunque il problema può essere risolto abbastanza facilmente, ecco come:

  1. andate nella cartella /wp-content/plugins/wpg2/g2image/langs/ ” presente nella vostra installazione di WordPress;
  2. in tale cartella, dovreste trovare un file del tipo a xx.js per ogni lingua. Nel caso dell’italiano il file si chiamerà it.js;
  3. ora aprite questo file con un editor di testo e sostituite tinyMCE.addToLang con tinyMCE.addI18n (che è il nuovo nome della funzione) stando attenti a non modificare nient’altro;
  4. salvate e sostituite il vecchio file;
  5. bene, ora potete utilizzare di nuovo l’editor WYSIWYG di WordPress!

Lascia un commento

Nome

Email (non verrà pubblicata)

Sito web (opzionale)

Quanto fa 3 + 5 ? (protezione antispam)




Seguici anche su Facebook

Per visualizzare questo contenuto è necessario accettare i cookie inviati dai Social Network.
Clicca qui per abilitare tutti i cookie per questo sito web.

Hai bisogno di un sito web?

Web&Dintorni